arrow-left arrow-right close decoration email facebook hr-decoration logo_small menu-decoration next prev twitter youtube
Welcome!

Welcome! This is where we talk about things, like games, space and pancakes.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID Sign In with Steam

Menu input bug

I'm having a pretty significant problem with the menus in We Happy Few. I'm going to describe the problem as clearly as possible, so bear with me.

The mouse cursor can move the entire width and height of the screen, but the clickable area of the screen seems to only cover a patch starting at the top left corner of the screen, and extending out roughly 3/4 of the size of the screen.
For example, if I attempt to click in the very bottom left corner of the screen, the area highlighted and clicked will be approximately 3/4 of the way down the left hand side of the screen. This makes it impossible to adjust graphics settings to experiment with finding a solution, as I am unable to click the "Apply changes" button at the very bottom of the screen.

This makes the game borderline impossible to actually play.

I'm currently using a GTX 1080 card and a Samsung 4K monitor. I'm not aware of any other parts inside my computer that could be affecting this.
  • LeeLee Member, Compulsion Team
    Hi there,

    This is a known issue that can occur where the game auto-detects the wrong resolution.
    The following steps should fix the issue:

    1 - From your Windows desktop, press the Windows key + R together.
    2 - Type in \Users\%USERNAME%\Documents\My Games\We Happy Few\Config\WindowsNoEditor
    3 - Open: GameUserSettings.ini
    4 - Change the following strings to the desired resolution:
    LastUserConfirmedResolutionSizeX=1280
    LastUserConfirmedResolutionSizeY=720
    This will change the resolution of the screen that the game auto-detects.
    5 - Once the values are changed, save the file and close it
    6 - Right-click the file and check "Read Only": this will prevent the game resetting the changes you've put in the file once you run the game.

    Doing so you should be able to play the game with that new resolution while also fixing the cursor positioning.
    If you still experience issues, it's possible old configuration data is causing the problem (Note: The below steps will reset your game options to default):

    1 - From your Windows desktop, press the Windows key + R together.
    2 - Type in \Users\%USERNAME%\Documents\My Games\We Happy Few
    3 - Delete the 'Config' folder
    4 - Launch the game

    This will clear your configuration files which might be causing incompatibility issues between versions.
    I hope this helps.

    Cheers,
    Lee
  • I've just tried both of these. There's no change in how the game behaves with the first. When I perform the second set of instructions, I get the prompt asking about the Compulsion data collection privacy policy just like the very first time I started the game, but beyond that, there's no change in cursor behavior.

    Is it possible this is a DPI scaling issue between the game and WIndows 7?
  • LeeLee Member, Compulsion Team
    That's possible. If you have different DPI settings, it may be helpful to test the other options or revert it to the default DPI settings. I would also suggest attempting to run the game in Windowed or Windowed Fullscreen mode and see if that helps.
  • ALright, I'll take a crack at it and come back with my results. I'm going to try the DPI settings first. If that's not successful, can you tell me what directory I can find the settings for windowed run options under? It's still not possible to click "Apply" when trying to change settings in the in-game menu due to the constraints the cursor is under.
  • Alright, I've got some results. Setting DPI settings back down to 100% has corrected the menu cursor problem. Unfortunately it's also made the cursor about the size of a pin's head and I'm straining to see the text as I write on the screen here. While I suspect WIndows 7's shaky handling of high-resolution DPI scaling settings to be largely to blame, it would still be nice to have a fix. :D
  • You might find this unusual. When the desktop resolution is set back down to 1440P(QHD) instead of 2160P (4K), the game behaves fine at any combination of internal settings and system DPI scaling.

    THe issue seems to appear exclusively while operating natively in 4K.
  • LeeLee Member, Compulsion Team
    Thanks for that information.

    This will help us correct the issue for the 1.0 release of the game. In the meantime, I'd suggest either playing at a lower resolution or with default DPI settings.

    Cheers,
    Lee
Sign In or Register to comment.