arrow-left arrow-right close decoration email facebook hr-decoration logo_small menu-decoration next prev twitter youtube
Welcome!

Welcome! This is where we talk about things, like games, space and pancakes.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID Sign In with Steam

"Enter Jubilator"

When trying to get out from the tunnels underground I first hade the problem with the cut-scene where it froze but after doing it multiple times I ran it to another problem. I respawn in the room as multiple times before, where you turn on the electricity and go out and jump in the jubilator, but this time it was different. the option to "Enter Jubilator" appears as usual and when pressing X on my X-box consol for PC to enter it disappears and I'm stuck. Can't enter de machine and cant go anywhere.

Thought this problem might have been solved in this weeks hotfix but it didn't, is there something I can do or will it be fixed in the near future?
  • having same issue just contact there twitter and leave a comment about this on there hotfix. they ussually respond and see easier there having same issue and was hoping listed in hotfix but none of the many bugs seen were there.
  • StephanieStephanie Compulsion Team
    Hi there! We had an update out this week which should fix these issues.
  • the game still gives me the option to enter jubilator but after pressing X to enter it still disappears so still have the problem sadly
  • StephanieStephanie Compulsion Team
    Sorry about that :( It should be fixed if you start a new game, this may be caused by playing on a broken save.
    If you want to continue this save, I recommend using ghost mode to fly back to street level (can be found in developer cheats menu)
Sign In or Register to comment.